Ubuntu/external infrastructure devices are partially down

Incident Report for testRigor

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 04:14 PDT

Update

A partial outage has been identified affecting tests executing on Linux OS and external infrastructure providers (i.e, BrowserStack, Sauce Labs etc).
Posted Jun 01, 2026 - 00:42 PDT

Investigating

We are currently investigating this issue.
Posted Jun 01, 2026 - 00:42 PDT
This incident affected: Test executors.